Get in touch
Back
Degraded

Some API requests failing

Started 23 Nov at 10:28am GMT, resolved 23 Nov at 05:27pm GMT.

Sirv API
Resolved

The sporadic API error was resolved. It impacted approximately 5% of API requests. It was caused by a misconfiguration when our engineers deployed a minor update to the API. Testing of the deployment by our engineers was cut-short by a Russian missile attack on Kyiv, causing electricity and internet to be lost. To prevent a repeat of such an issue, new deployments will now be tested by a secondary team in UK. We would like to thank all nations who are providing air defence systems to help protect Ukrainian infrastructure and civilians from future attacks. Despite Russia's war, it is business-as-usual here at Sirv - during 2022, we have grown our team, expanded our CDN and launched many new features. Thank you for your support!

Posted 23 Nov at 05:27pm GMT.
Created

A small number of requests to api.sirv.com are returning 502 or 504 responses. The issue is being investigated.

Posted 23 Nov at 10:28am GMT.