Get in touch
Back
Degraded

Some repeat visitors seeing "too many redirects" error

Started 26 Dec at 08:00am GMT, resolved 27 Dec at 06:22am GMT.

CDN request from N.America
Resolved

The issue has been resolved. Chrome browsers started caching 307 Temporary Redirect responses, which caused a local infinite loop on the users device. 307 responses are temporary, so they should not be cached by browsers. Indeed, Sirv has always used the same 307 logic and responses have never been cached, so this may be a Chrome bug. We solved the issue by adding a header explicitly telling browsers not to cache the response. This should also prevent the issue from occurring in future.

We estimate that fewer than 1% of requests were impacted, affecting repeat visitors for files that had been previously cached and since deleted from the CDN cache.

Posted 27 Dec at 06:22am GMT.
Created

Some users in US are occasionally seeing a "307 - Too many redirects" error in their browser. This is sporadic and affects some images but not others. We are investigating the issue.

Posted 26 Dec at 08:00am GMT.