Back to overview
Degraded

Some requests from India CDN return 404

Feb 23 at 06:25am GMT

Resolved
Feb 23 at 07:55am GMT

The issue was resolved at 0755 UTC.

At 0625 UTC, some requests to the Indore CDN POP which serves India started to return a 404 response (file not found), instead of a 200 response (OK). The issue occurred 14 hours after an update to all CDN servers worldwide. All POPs behaved healthily, including the India POP but the Indore POP hadn’t updated successfully and eventually started to return errors.

Once the issue had been identified, it was resolved by re-deploying the update to the India POP. During the incident, 94% of requests returned an error. Requests to all other countries were returned as normal.

To prevent this issue from recurring, a new automated deployment rule is being created for a part of the deployment process where there had been only a human check. An additional alerting metric is also being created, to identify a situation in which a deployment has failed.

We apologise to all customers who were impacted by this incident and we are evaluating other changes that may help prevent any possible repeat of the issue. If a CDN issue like this occurs, one immediate solution within your control is to disable the CDN temporarily in your Sirv settings here: https://my.sirv.com/#/account/settings/domains

Thanks for using Sirv.

Created
Feb 23 at 06:25am GMT

The India CDN POP started returning 404 responses for some files which should be returning 200 (OK) responses. The cause of this is being investigated.