Back to overview
Degraded

Some API upload requests failing

May 22 at 12:31pm BST
Affected services
Sirv API

Resolved
May 22 at 01:37pm BST

This issue resolved itself once the load on the upload API started falling. During the period, approximately 97% of uploads succeeded and 3% failed. REST API uploads are limited per hour, to the amount specified on the Usage page of your Sirv account https://my.sirv.com/#/account/usage. If you use the REST API for uploading images, best-practice is to check the response for each upload request and if you receive an error response (400, 401, 429 etc.) then pause uploads and retry later. Refer to the docs here: https://sirv.com/help/articles/sirv-rest-api/#error-handling-guide

Created
May 22 at 12:31pm BST

A small number of REST API upload requests are failing due to very high load.