Back to overview
Degraded

Some API upload requests failing

May 22 at 03:57pm BST
Affected services
Sirv API

Resolved
May 22 at 04:06pm BST

The issue resolved itself within 9 minutes once upload volume normalised. During the period, approximately 98% of uploads succeeded and 2% failed. REST API uploads are limited per hour, to the amount specified on the Usage page of your Sirv account https://my.sirv.com/#/account/usage. If you use the REST API for uploading images, best-practice is to check the response for each upload request and if you receive an error response (400, 401, 429 etc.) then pause uploads and retry later. Refer to the docs here: https://sirv.com/help/articles/sirv-rest-api/#error-handling-guide

Created
May 22 at 03:57pm BST

The earlier issue of high upload usage returned, with a small number of API upload failing.